Virtual Instrumentation With LabVIEW

B! Power Spectrum with Lab¥IEW. i Front Panel

File Edit ©Operate Tools Browse ‘Window Help

& ®

13pt Application Font

Signal Frequency Sine and Square Waves
1
Sine Wave Square Wave
_ _ w 0.5
40 E 40 E . E
30: 30: 7 0 B i i i
: : £ s &= Power Spectrum with Lab¥IEW.vi Block Diagram
20= 20= b
10_3 10—: 4 File Edit Operate Tools Browse ‘Window Help
g g 0.0E+0 B i@ ol 13pt Application Font ~| &5~
o .- 0 2| & D@. of
[ O[u][@] el ]os | E=
| -~
SILRTE Power Spel
s AT g e
0 X i | .
. o =P ine and Square Waves
g - preor savere aved
Square Frequency E -100 : H
o & w0 25 1 . .
s o 7 E B Simulate Signal
PN | e i | =
= 3
2000 Equare Wave + H " '
Freaqus e Spectral ‘Wit LabWIEW
B B Measurements Power spectrum|| Measurement
. =]} Signals ,ﬁ File
£ » Poweer Speckrum Signials
Equare Frequency|, E i =
i Simulate Signalz
b i Square
=
toé
| ETOF
| L]
i
v
< >

nl.com N7 NATIONAL
¥ INSTRUMENTS


http://www.ni.com/

Course Goals

» Understand the components of a Virtual Instrument

* Introduce LabVIEW and common LabVIEW functions
» Create a subroutine in LabVIEW

» Work with Arrays, Clusters, and Structures

* Develop in Basic Programming Architectures
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Section |

* LabVIEW terms
» Components of a LabVIEW application
* LabVIEW programming tools

» Creating an application in LabVIEW
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LabVIEW Programs Are Called Virtual Instruments (Vls)
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VI Front Panel
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VI Block Diagram
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’ Express Vls, Vis and Functions

» Express Vls: interactive Vls with configurable dialog page Comlex
» Standard VIs: modularized Vls customized by wiring

(easy to use)

* Functions: fundamental operating elements of ~  mutiey sinoe
LabVIEW; no front panel or block diagram B ]
Function

Express VI Standard VI

NATIONAL
INSTRUMENTS
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Tools Palette

* Floating Palette
« Used to operate and modify
front panel and block diagram

objects.
2% & |  Automatic Selection Tool
Iy Operating Tool & Scrolling Tool
% Ppositioning/Resizing Tool ‘@ Breakpoint Tool
A Labeling Tool ‘& Probe Tool
¢ Wiring Tool # Color Copy Tool

%/ Coloring Tool

Shortcut Menu Tool
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Status Toolbar
Iilﬁ i _I @ |I'EI I | 13pt Application Fonk |TI|M|E‘ IM
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the Diagram Toolbar
@ Abort Execution

M| pause/Continue Button 2 Eﬁ?tcountion Highlighting

13pt Application Fonk |~r' Text Settin gs

;,;,-ri Align Objects
Tﬁ:vi Distribute Objects

EI Step Into Button
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E Step Out Button
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Creating a VI

Front Panel Window

Block Diagram Window

] 6\ +Ei
i Add
123 o ¥
Contr_ol Indicator
Terminals o Terminals
8 E Lz
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Creating a VI - Block Diagram

po

> Context Help |§||E|

Subtract

Computes the difference of
khe inputs,

Click here for more help.
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Wiring Tips — Block Diagram

Wiring “Hot Spot” Click To Select Wires
% B e > B
single-click double-click triple-click
Use Automatic Clean Up Wiring
Wire Routing

E Create Wire Branch
1-2 Delete Wire Branch

b s : Insert
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Dataflow Programming

* Block diagram executes

dependent on the flow of data; o=’ Result 1
block diagram does NOT 2 > S
execute left to right Mumber 2

8 (B

Randorn Murnber (0-17
* Node executes when data is Mumber 3 sz

available to ALL input terminals |z >k

Mumber ¢ e

* Nodes supply data to all output |12
terminals when done
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Help Options

* Context Help

Context Help

VISS session GEEEL]
¢ On I Ine h el p errdr in {no error] _@ errar ouk
* Lock hel P HP344014A Close.vi

° S| m p | e/CO m p I ex D| ag ram h el p . the I,I'li?‘l interface and returns the instrument
« Ctrl +H

Online reference

* All menus online
* Pop up on functions in diagram to access online info directly
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—
Customize LabVIEW

 Launch LabVIEW and create a Blank VI.

» Set Up Programming Pallette
— Click on Window -> Show Block Diagram

—Right Click on the blank white screen to bring up the
functions pallette.

—Click Search - this takes a minute the first time
—Click View -> Change Visable Categories

<7 NATIONAL

’ INSTRUMENTS
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Customize LabVIEW (cont.)

B Change Yisible Categories

[+ Programring

[ Measuremnent Lo
[T Imstrument IO Deselect all |
[ Vision and Mation

Select all

|»

[T Connectiviey

[T Contral Design & Simulation
¥ Express

[T Addons

[ Favorites

[T User Libraries ||
[ Seleck a WL,

[T FPiaA Interface é

K | Cancel | Help

— Check Programming, Measurement I/O, Express, and
Selecta VI.... Click OK
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Customize LabVIEW (cont.)

» Set Options

—Click on Tools -> Options...

* Click on Block Diagram
— Uncheck Enable automatic wire routing
— Uncheck Place front panel terminals as icons

* Click on Environment
— Uncheck Maximum undo steps per VI -> Use default
— Set Maximum undo steps per VI to 99

» Click OK
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Exercise 1 - Convert °C to °F

i Conwvert C to F (Ex1).¥i Front Panel *

File Edit Qperate Tools Browse Window Help

E‘@ |@| ||I | 13pt Application Font |-1|M|EI|%I IEI @



\ni.com\
\www.ni.com\
http://www.ni.com/

Debugging Techniques

* Finding Errors

F‘: Click on broken Run button
Window showing error appears

« Execution Highlighting

Click on Execution Highlighting button; data
— == flow is animated using bubbles. Values are
displayed on wires.

* Probe

SN 3l Right-click on wire to display probe and it
. shows data as it flows through wire segment

+Er You can also select Probe tool from Tools
palette and click on wire
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Section Il - SubVis

¥ Sample Program.vi Front Panel * |._||E||£| k> Sample Program.vi Block Diagram * |-_||E”£|
File Edit Operate Tools Browse Window Help ﬂ File Edit Operate Tools Browse Window Help ﬂ

[ @] @[] 130¢ appication Fort [~ | ; (S]] @[1][@] sl [1a0 ampicatif s
L) L]

File Edit Operste Tools Bkowse ‘Window Help

* What is a subVI? 21| ([0 pllo st |3
»|

» Making an icon and =
connector for a subVI ]

* Using a VIl as a subV|

ni.com NATIONAL
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SubVls

A SubVI is a VI that can be used within another VI
e Similar to a subroutine

* Advantages

— Modular

— Easier to debug
—Don’t have to recreate code
—Require less memory
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lcon and Connector

b i ceeeeeeeeeees HTE.F,-,F.

T emperature

diagrams

* An icon represents a VI in other block

* A connector shows available
terminals for data transfer
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Steps to Create a SubVI

* Create the Icon

» Create the Connector

* Assign Terminals

 Save the VI

* Insert the VI into a Top Level VI
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Create the Icon

* Right-click on the icon in the
block diagram or front panel

B 2w

[(=1,01]
Z

| L-mT
O, 2]

16 Calors

256 Colars

[(x1,01]
z

| L mE
Pl 2]

Copy From:
&3 Black & White
&2 16 Colors
£} 256 Colors

[ Show Terminals

Ik

Zancel

Help

ni.com
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Create the Connector

Right click on the icon pane (front panel only)

File Edit Operate Tools Browse ‘Window Help

| ]@ 1] |13|:|I: Application Font vlf «||qe~ 5= Y1 Propetties...
2 ®.u| M EEET Edit Icon...

Show Conneckor

Find &ll Instances

add Terminal

Rermowve Terminal
Fatterns 2
F.okbakte 90 Degrees

Flip Horizonkal

Flip Wertical

Disconnect &ll Terminals

Disconnect This Terminal
This Connection Is 3
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Assign Terminals

+ NDE b |

File Edit Operate Tools Browse ‘Window Help

@ @ﬂl 13pt Application Fant |1rl o
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Insert the SubVl into a Top Level VI

Accessing user-made subVis

Functions >>All Functions >> Select a VI
Or

Drag icon onto target diagram

(- [B)fX] &) untitied 4 Block Diagra

File Edit Operate Toals Brov

= WRELOeP

:

§ e

- =

EE
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Exercise 2 - Make C2F.vi a SubVI

i Conwvert C to F (Ex1).¥i Front Panel *

File Edit Qperate Tools Browse Window Help

E‘@ |@| ||I | 13pt Application Font |-1|M|EI|%I IEI @
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Section lll - Loops and Charts

* For Loop
* While Loop
* Charts

* Multiplots
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Loops

Randu:um Murmber (0-1)

*While Loops & o
— Have lteration Terminal
— Always Run at least Once

— Run According to Conditional
Terminal

* For Loops

— Have lteration Terminal

— Run According to input N of
Count Terminal

R.andom Mumber {0-1]
=T

&
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Loops (cont.)
1. Select the loop

= Structures |E||EI

2. Enclose code to be repeated

s FR 002
1
I . :
wwE : C—*F 1
1
] 1
m EI x ' b degt |
— : deq F b 1
H 020 1
g ! :
1

____________________________________________________
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Section IV - Case & Sequence Structures,
Formula Nodes
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Case Structures

* In the Structures subpalette of Functions palette
* Enclose nodes or drag them inside the structure
 Stacked like a deck of cards, only one case visible

Functions >> Execution control
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Sequence Structures

* In the Execution Control subpalette of Functions palette
» Executes diagrams sequentially
 Right-click to add new frame

4= Functions (1 search

& o ¢ e

]-L*J; b4 e

H
Input Analysis Output IUser Libraries K ) T
@’ B3| | Q| DAQ Assistant
] - A
<1 Execution Control data b ;
Exec Ctrl htd [T

While Loop Flat Sequence  Case Structure

B |[@

Time Delay Elapsed Time
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Formula Nodes

* [n the Structures subpalette

* Implement complicated equations

 Variables created at border

* Variable names are case sensitive

« Each statement must terminate with a semicolon (;)
e Context Help Window shows available functions

s

J Note semicolon

oukput 'u'arial:lle|

[ 1.2
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Section V - Arrays and Graphs

« Have LabVIEW build arrays automatically by
wiring a scalar (single value) to the edge of
For/While loop

* Multi Plot graphs
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b Untitled 2 Front Panel *
File Edt Operate Tools Browse ‘Window Help

LB

DECME T F

A

Creating an Array with a Loop

k> Untitled 2 Block Diagram *

File Edit Operate Tools Browse ‘Window Help

* Loops accumulate arrays at their boundaries —
use Mouse to resize
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Creating 2D Arrays

> Untitled 2 Block Diagram *
File Edit ©Operate Tools Browse ‘Window Help

®| Ill @ |I..ullﬁ'luj_ 13pk Application Fonk |'!|M|£l m
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&= Untitled 9 Block Diagram ™

File Edit Cperate Tools Browse ‘Window Help

Array Functions - Basics

B Array @JE alif:
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Search 10 Arra

sizes]]
I3

lemnent

123

DE
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Functions >> All functions>> Array

k> Untitled 9 Front Panel ®

File Edit Operate Tools Browse ‘Window Help
Iﬂ@ 13pt Application Font |v| ;,;.vl Tu:vl ﬁvl C.';vl
A



\ni.com\
\www.ni.com\
http://www.ni.com/

& Build Array.vi Block Diagram *

File Edit

Operate Tools Browse ‘Window Help
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& Build Array.vi Front Panel *
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Graphs

 Selected from the Graph palette of Controls menu
Controls>>All Controls>>Graphs

Waveform Graph — Plot an array of
numbers against their indices

Express XY Graph — Plot one array
against another
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Graphs

Waveform Graph

armplitude

k2

Time o |

Time Mﬂﬂ

Cusar 0 20 1.36 ﬂﬂi‘
Amplitude Eﬂﬂ Cursar 1 13 1.22 ﬂﬂi‘

Right-Click on the Graph and choose Properties

to Interactively Customize
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Exercise 3 — Instantiate C2F.vi in a Top Level

VI

«Start with Block Diagram from Slide 39
*Add a case for Random * 100 or |

|nstantiate Cto F
Celsius input.

SubVIl in the | case and use | as the

*Add graphs for the 1D and 2D outputs

eTurnon Dots to s
Execution Highlig

ni.com

now how many points in each trace

nting
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