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1. Introduction

We use Cadence Encounter for placing and routing standard cells, but also for power
routing and clock tree synthesis. The Verilog gate-level netlist generated by Synopsys
DC has no physical information: it is just a netlist, so the Cadence Encounter will first try
and do a rough placement of all of the gates into rows on the chip. Cadence Encounter
will then do some preliminary routing, and iterate between more and more detailed
placement and routing until it reaches the target cycle time (or gives up). Cadence
Encounter will also route all of the power and ground rails in a grid and connect this grid
to the power and ground pins of each standard cell, and Cadence Encounter will
automatically generate a clock tree to distribute the clock to all sequential state
elements with hopefully low skew. The automated flow for place-and-route is much
more sophisticated compared to what we did in the previous tutorial.

2. Login to the Linux Lab server

Detailed explanation is in ese566-linux-tutorial.pdf

3. Getting prepared using Design Compiler

In the terminal, change path to your project directory, and compile your code using
design compiler.

(If you don’t know how to use design compiler, look at ese566-dc-tutorial.pdf)

4. Encounter

4.1 Start Encounter

Download the “Default.view” and modify it according to your design for MMMC view
definition file later. Please specify the name of the .sdc file used in your synthesis script.
It should be the .sdc file generated by Design Compiler in the previous design step.

/mne generated by Design Compiler.

# Version:1.0 MMMC View Daefinition EW change it according to your desi
2 # Do Not Remove Above Line
create library set -name vitvt_tsmcl80 -timing {/project/linuxlab/cadence/vendors/VIVI/vtvt tsmcl80/Synopsys Libraries/libs/vtvt_tsmcl80.lib}
¢ create_constraint mode -name constraint rule -sde_files —
© create_delay corner -name vtvt_tsmcl80 -library set (vtvt_tsmcl80)

create_analysis wiew -name cnn;traint_rule -delay_corner vtvt_tamcl80 -constraint mode {constraint_rule)
set_analysis_wiew -setup {conatraint_rule) -hold {constraint_rule}

Figure 4.1 Default.view
Then execute the following command in the shell to start encounter
% encounter

You will get the following printout in the terminal and a window pops up which looks like
the one as below. This window will lead to the design window.


http://classes.engineering.wustl.edu/ese566/Tutorial/ese566-linux-tutorial.pdf
http://classes.engineering.wustl.edu/ese566/Tutorial/ese566-dc-tutorial.pdf
http://classes.engineering.wustl.edu/ese566/Configs/Default.view
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Figure 4.2 Command and the printout of “encounter”

cadence’

Encounter® Digital Inplementation System
RTL-to-GDSII
version 14.20

Copyright & 1996-2014 Cadence Design Systerns, Inc. All rights reserved worldwice.
Cadence, the Cadence logo and Encounter are registered tradernarks of Cadence Design
Systerns, Inc. Al others are the property of their respective holders.

Figure 4.3 The window popped out when execute “encounter”
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Encounter(R) RTL-to-GDSII System 14.23 - fhomefwarehousefsriharshakondapalli

Non Florplsn Poyw Hace Cotmtzs Gk foute Dming Ve Oplone VS Tods Flowg, Holp cadence

‘Figure 4.4 The design window of “encounter”

4.2 Import Design

Go to “File->Import Design” and add files to import your netlist file, and you have to:

e Provide synthesized Verilog (.syn.v) which is the output netlist file generated by
Design Compiler in the previous design step.

e Provide path for the LEF file from technology library. Set path to
“/project/linuxlab/cadence/vendors/VTVT/vtvt_tsmc180/vivt tsmc180_lef’ and select
the “vtvt_tsmc180.lef” file from the folder.

e Provide the supply nets as vdd! and gnd! in the appropriate boxes as below. These
represent the global power supply and ground net in your design.

e Load the “Default.view” edited above for MMMC view definition file

Click “OK” to finish

2. Uncollapse or

ollapse the directoryefiist Fites
Encounter(R) R

Hetlist: t File: ntersyn v

Netlist Files:

Netlist Selection:

fiew Parttion Floor | eri
® Verilog

Files C-ID

Top Cell. Auta Aesign @ By User

Select the netlist file generate:
by Design Compiler(.syn.v file

o 0A

Technology/Physical Libraries:
® 0A

Refarence Libraries
Bhsiract View Names
Layout View Names
_ LEF Flles
Floorplan
10 Assignment File: [
Fiters: ~ Netist Files (-
e G =
Pouser Nets
Ground Nets Slese,
CPF Flle: [
Analysis Configuration
MMM View Difinition File [

Create Analysis Configuration

[ ox ] Save Load Cancel Help ‘

Figure 4.4 Import netlist
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3. Uncollapse or
ollapse the director;

LEF File: -_tsmc180.lef LEF Selection:

Tetist:
o verilog LEE Gkt [Eaiencervendors VTV T tsmc B0vtvt tsmcta0_ler [ 18
ifie=y Counter.syn.y ._I [ vii_tsme160_noiabel
Tap Cell: Auto Assign @ By User. MWE
_ o8
= @vlvl tsmc.lef file(library file
Technology/Physical Libraries: - - -
Coa i
CSelectherd, iane 2 Click here >
D Fies Zeadence/vendurs/V TV TAIVI_Isme] 80/vivi_tsmc] 60_lerivi_teme 501
Floorplan
B

10 Assignment File: Sr—— = °
Filters es (e
Power EEEEY LED =
Fower Nets: G
Ground hets

CPF Flle =]

Analysis Configuration
MMIVC View Definition File: [
Create Analysis Configuratian

D = Lot Gancel kb ‘

Figure 4.5 Import LEF file

Design Import

Hetlist:
@ Vverilog

Files: Countersyn.v

Tiop Cell:. Auto Assign e By User.
oA

Technology/Physical Libraries:
(o1

|

® LEF Files bivadence/vendors/VTYT/vivi_temc 80/vive_tsmel S0_lefvivi_tsmc180.0ef ..

Floorplan

. Specify the power ne =]

_Load. _Cangel _Help

Figure 4.6 Add poWer net and MMMC view file

Then, you will be seeing a blank screen with horizontal lines on your main window
(layout window). Press “f” for fit screen view of layout.

Figure 4.7 The initial layout window



ESE566A Modern System-on-Chip Design, Spring 2017

Specify “floorplan” options in the “Floorplan->Specify Floorplan” and set the values as
figure 4.8.

Specify Floorpla
& ParitionQ@RLELOETE Foyer Place Optimize Cloc paSify Floorpian

——e . “Basic || Advanced
¢ Speciry Floorplan .
Design Dimensions

Spuctured Data Path... Specify By: & Size  DiedO/Core Coordinates

Autamatic Floorplan » : : : —
& Care Size by: & Aspect Ratio: Ratio (H): 1
Resize Floomlan e Core Utilization: | 0.699833
Relalive Floorpian b _ Cell Utilization: ~ 0 635835
_ Dimension: Width: 5382
Row ¥ Height: 45,36
| Floorplan Toolbox.. _ Die Size hy: Width: s s

Height: 4536

Edit Floorplan 4 Core Margins hy:e Core to 10 Boundary

3'1:—]]_ Floorolan Ctrl+M _ Core to Dig Boundary

Check Floorplan... Core to Len€__ 0.0 Core to TopKe_10.0_D

Core to Right€C_ 10.0_Dore to Botto »
Clear Floorplan

Die Size Calculation Use: _ 2% 10 Height & Min 10 HE

Floorplan Origin at: ® Lower Left Carmner _ Center
Instance Group J Unit: Micron
Geperale Regrouped MNetlist
Generate Floorplan J [ oK ] _opply _Cancel _ _ Help

Figure 4.8 Specify Floorplan
Set the global nets vdd! and gnd! at “Power->Connect Global Nets”.

Global Net Connections Global Net Connections
Connection List Power Ground Connection Connection List Power Ground Connection
Connect & — Connect
and Bl
& Pin & Pin
~ Tie High « Tie High
— Tie Low o o~ Tie Low
Instance Basepkme: * Instance Baserme: *
Pin Hame (#uddL) Pin Name(dC gnd! )
. Met Bazename: . Met Basename:

Scope Scope

:I _ Single Instance: — % _ single Instance: ~
e Under Module: & Under Module
 Under Power Domain:  Under Power Domain:
. Under H@ Iy 0o umoo ury: 0.0 ﬂl . Under Rg an ly: 0.0 ur: 0.0 ury: 0.0 ﬂl
_ Apply Al — Apply Al
Ta Global Ni vdd\) Ta Global ‘|

vem & connection
Verbo
_Delete
m Chesk Reset Cancel Help _Check _Beset . Help
\ J Heset Lancel Help_

Updiate Delete

Figure 4.9 Set the global nets

Go to “Power->Add Ring” and set Net pins to vdd!, gnd!. And you change width and
spacing of power ring.
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2. Press Ctrl+Left Click to multi-select >

G é‘,* Basic || Advanced = Wia Generation THETS Chosen Nets

o <D

Riny Type

Connect Global Nets

4 oply Voltage »
Power Plagning
Povrer Analysis »
Bail Analysis »
Report »

Edit Povrer Via

Create Power/Ground Pin
PG Cut/Repalr

& Core ring(s) contouring
& Around core boundary  Along KO boundary
__ Exclude selected objects
 Block ringis) around
® Each block
Each reef
Selected power domainfences/reefs
Each selected block and/or group of core rows
Clusters of selected hlocks and/or groups of Core rows
With shared ring edges
 User defined cootdinates
e Core ring Elock ring

Cancel Help
L=y L

Ring Configuration

Top: Bottom: Left: Right:
Layer: metall H ¥ metall H » | metalz ¥ » | metalz ¥ »
Width: 045 045 045 045
Spacing: 045 045 045 045 Updale
Offset. . Centerin channel @& Specify
081 0.1 0.1 0.1
.~ Option 3et

ool Bing @ption

@ set Mode Apply Defaults Cancel Help ‘

Figure 4.10 Add power ring

We can also edit the pin placement in our design. Go to “Edit->Pin Editor”. Group some
pins and you can place them on left or right side of the design. If you don’t specify
Encounter will be taking appropriate placement during optimization. Once done click
“OK”

> = Pin Editor
- . Pin Attribute - 2 Selet sides
Partition: Counter n_ Clone : e '
# MoverResize/Reshape  ShisR B — Pin Name(s): c[0] c[1] c[2] c|B] c[4] clk rst
? Copy  Show Partition Edge Number
O Atribute Editor o T
0B Browser Y
Gom
Find/Select Object ShiftsF
%% Deselect Al CHilD
# Highlight Selected b Location
“# Clear Highlight 3 D 4 _ Update attribute
Edit Highlight Color.. _ Assign location
Din Backgraund F12 & Spread
Edit Pin Group 2 Spread Typeg_
Edit Net Group _ Pattern
Edit Pin Guide Pin Group
Bus Guide v 3
Side/Group/Layer: All »
. ]
ire » ‘ clk (Left) @
Craate Non Default Rule rst (Lef®

Start to end Direction|_Clockwise »
Spacing: 7.29
Unit:® Micron _ Layer Pitch
.~ Snap To

_ Manufacturing Grid
 User Grid

E‘ll I:"3| bl =4 | | @ Layer Track

__ Assign Fixed Status
_ Reverse Order i Fix Overlapping
Sor By @ Nane @ Focstion __ Honar Partition and/ar Pin-Level Constraints

Find Pins: " [E1]|| « Batch Mode

Use: SIGNAL »

~ Group Bus

sl

Align... Cancel Help

Figure 4.11 Pin Editor
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Watch how your layout is changing while you are setting the parameters in the GUI.

\
\
|
-
\
\
\
|
b
1
<
\
\
b
|
b
1
4
1
\
\

,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, ]

Figure 4.12 The layout view after edit pins
Place the vdd! and gnd! in the design. Go to “Route->Special Route”

SRoute Net Selection

Encounter(F

o Chosen Nets
~ e Basic | Advanced | Via Generation Yy ‘m
ming Verfy Optlons e i
B Netts): gnal vl @
SRoute
I o Block Pins » Padi Pins  Pad Rings 2 Follow Pins w2 Floating Stripes Dneleré
Routing Control
Layer Change Control
Top Layer. _metali »_ Bottom Layer: | metall »
o Allow Jogging o éllow Layer Change
_ Area Power Domain Selection [ ok ] Cancel Help
e Al
" m o Selected
 Named

__ Delste Existing Routes
__ Generate Progress Messages
_Mode Setup

Target Editing Options

[(Cox ) _Anply Detautts | Cancel Help

Figure 4.13 Place vdd! and gnd!
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Figure 4.14 The layout after place vdd! and gnd!

Now we are all set to place the design. And then we go to “Place->Place Standard Cell”.
Click OK.

SEENYOptimize Clock F Place

Specify L4 #& Run Full Placement _ RBun Incremental Placement _ Bun Flacement In Floarplan tMode

Optimization Options
o Include Pre-Place Optimization

Plac aakba

A —

Place Standard Cell...
E el __ Include In-Flace Optimization

Pla are

Mumber of Lacal CPU{E): 1 36t Multiple CPU...

: ‘m’ _Apply _ Mode Defaulls _Cancel _ Help
Physical Cell »

Check Flacement...

CQuery Density »

Figure 4.15 Place standard cell

Figure 4.16 The result after place standard cell
4.3 Clock tree synthesis

e Download Clock.ctstch and place it in working directory.

e Download Clock.tcl and place it in working directory.

e Open Clock.tcl using gedit and copy the content line by line to the encounter
terminal and execute it.


http://classes.engineering.wustl.edu/ese566/Configs/Clock.ctstch
http://classes.engineering.wustl.edu/ese566/Configs/Clock.tcl
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Terminal - dengxue.yan@linuxlabO09:~/ESE461/DCTutorial
File Edit Wiew Terminal Tabs Help

ncounter

Figure 4.17 Partial of clock tree synthesis commands and results
4.4 NanoRoute
As part of routing go to “Route->NanoRoute->Route”. And click OK.

—
QT ER)Timing  Verify  Options Tools Flowg He NanoRoute
P —

Generate Routing Guide - e wi
Gdd &3 o g
| Trial Route R

Routing Phase

« Detail Route  Start Iteration default End lteration default
Post Route Optimization __ Optimize Via __ Optimize Wire

Metal Fill 4 Concurrent Routing Features

Yia Fil ongestion

« Fix Antenna __ Insert Diodes

__ Timing Driven fion B e SMART.
__ Sl Driven

__ Litho Driven _I

__ Post Route Litho Repair

Routing Control

__ Selected Nets Only Bottom Layer default Top Layer default
__ ECO Route

__ Area Route Area | |2
Joh Control

v Auto Stop
Number of Local CPU(s): 1
Numher of CPU(s) per Remote Machine: 1
Number of Remote Machine(s): 0
_Set Multiple CPU...

@ Apply | | Aftribute | | Mode Save Load Close __Help

Figure 4.18 Nano route

You will see that your design got placed in the layout and all the interconnections are
done.
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4.5 Add Filler.

“Place->Physical Cell->Add Filler”. Select “filler” cell name and click OK.

Scan Chain
Check Placement
Display
Gluery Density

Prefis FILLER

Al Cap..

ler

Add 140 Filler..
Delete KO Filler,

E\a_:e DOptimize Clock Route Timing WVerify o Select Filler Cells
Specify > o] Cell W filli Selectable Cells List
apecity & 3:« 57 I ame(s) filler @I

filler

Flace Jtag.
Place Standard Cell.. Power Domain _Select
. _ Mo DRC
Flace Spare Cell
| Mark Fixed
Refine Placement __ Fill &rea
ECO Placement
Physical Cell R
e — Add Well Tap
1 We
i g Apply | _Mode | Cancel ;| Help

Close

Check Filler

Figure 4.19 Add Filler
4.6 Verification

Once Place and Route is done:

e Go to “Verify->Verify Geometry”. Click OK.
e Go to “Verify->DRC". Click OK

e Go to “Verify-> Connectivity”. Click OK

Check the terminal every time for any violations and warnings.

Terminal - dengxue.yan@linuxlab009:~/ESE461/D CTutorial

Optlons Tools Verify Geometry

Verily Geomsry... Basic = Advanced
Vellly DRC...

Verification Area

Fle Edit Wiew Terminal Tabs Help

Verify Connectivity
N & Entire area

Werify Process Antenna.. B

_ Specify

Yerify AC Limit, - = = -

WYerify Bus Guide...

Verify End Cap Layer Range » »
Yerify Metal Density Check.
Werify Cut Density.
Verify Power Via..

o Minimum Width o Minimum Spacing
 Minimum Area  Same Net Spacing

o Short _ Geometry Antenna

« Cell Overlap __ Off Routing Grid

o Insufiicient Metal Overlap « Off Manufacturing Grid

 MinHaole o Implant Check

 Minimum Cut  MinStep

 Via Enclosure o Merged MGrid Check

Allow
» FinIn Blockage T
~ Same Cell Violations ‘

Different Cell Violations
__ Owerlap of Pad Filler Cells
Overlap of Routing Blackages &nd Pins
__ Ovwerlap of Routing Blockage A&nd Cell Blockage

@ Apply Beset _Cancel _ Help
Figure 4.20 Verify Geometry

lencounter 8

10
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Verification Complete

Figure 4.21 Verify DRC

0 Viols.

*¥** End Verify DRC (CPU: 0:00:00.1

Violations

1 complete 0@ Viols.

Verify DRC kdckdkkdkk End: VERIFY CONNECTIVITY choksksdoksok
verity Geometry o] R Verification Complete 0 Viols. 0O Wrngs.
. (CPU Time: 0:00:00.0 MEM: 0.000M)
vy, Verification Area

‘erlfy Bracess Antenna & Entire area % i ; 5

seiify 4C Limt 5 encounter 8> *** Starting Verify DRC (MEM: 785.1) #*#

Verry Bus Guids

Vo) End Co VERIFY Starting Verification

Verify Mg ensity __ Layer Range o » - » VERIFY Initializ ng
VERIFY < .. Deleting Existir
VERIFY g .. Creating Sub-Areas
VERIFY Using new threading
VERIFY DRC Sub-Area 1 of 1

@ a— o bep VERIFY DRC Sub-Area

ELAPSED TIME: 0.00 MEM: 0.1M) ***

Verify Connectivity

Het Type

e All

. Regular Cnly

_ Special Only

Hets

s All

_ Selected

_ Mamed
Check

Verify Power Via

» UnConnected Fin  Unrouted Met
 DanglingWire (Antenna) » Weakly Connected Pin
_ Geometry Connectivity | Keep Previous Results
» Soft PG Connect __ Raw Vialations Mark

» Open

__ Connectivity Loop

__ Geametry Loop

__ Divide Power Met

__ Use Virtual Connection

_ T5V Die abstract File

welify Connectivity Repart: Counter.conn.rpt i
Report Limits

Errar: 1000
‘arning: 50

_Set Multiple CPU.

>

Anply _Cancel _ Help

L ke

Wr

Figure 4.22 Verify Connectivity
4.7 Timing report

Timing Analysis

Basic | Advanced

__ Use Existing Extraction and Timing Data
Design Stage
o Pre-Place @ Pre-CTS _ Post-CTS  PostRoute L Sign-Off

Debug Timing

Analysis Type

© Setup L Hold

Reporting Options
Number of Paths: 50

Report file(s) Prefoc  Counter_preCTS
Output Directory:  timingReparts

_cancel Help

Figure 4.22 Generating timing report

11
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4.8 Additional Information

Save your design for later use. “File -> Save”. Give an output file name for each
floorplan, Place, Netlist and DEF file so that you can save all the optimization options
and can load it later.

Edit View Parttion Floorplan Power Pl

Import Dasign... i @' :: 4 u’

Restore Design.. o -

ECO Design... 1 m E;,
& Save Design. F2

Create OA Library...

Import RTL

Load »

BT

artition

Check Design
Report 4

Floorplan )
170 File
Place

Ext

DEF
PDEF
Timing Budget.

GDS/OASIS

Figure 4.23 Save your project
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